Vercel Analytics supports Next.js 10+ with zero-configuration required. Projects on Next.js 9 or earlier are required to upgrade to enable Vercel Analytics.

An example of the Analytics tab on the project view.

Read the Analytics Overview to learn how to enable Next.js Analytics for your application.